What PHP versions does Amasty support?

What PHP versions does Amasty support?


Magento supports 
Amasty supports
PHP 7.4, 8.1, 8.2
Existing extensions: PHP 7.3+
New extensions: 7.4, 8.1, 8.2

Since July 14, 2021, we don't support the PHP 7.1 and 7.2 versions.
      • Related Articles

      • Will the module work on Magento x.x?

        We provide compatibility of our modules with currently supported Magento versions (in accordance with Magento lifecycle policy ) . For greater convenience, we've set up an approximate schedule for Magento versions that we test and support. Tested ...
      • How do we help our clients with conflicts between Mageplaza and our modules?

        Sometimes it happens that various problems arise when installing extensions, which from time to time interfere with the normal functioning of the store. This article will tell you several cases of how our support team helps our clients solve ...
      • Do Amasty extensions work with OpenSearch and LiveSearch?

        Our primary focus is on ensuring the flawless functioning of our modules in accordance with all Magento specifications. Currently, Amasty extensions are compatible with OpenSearch versions 1.2 and 2.5. These versions align with the requirements ...
      • Are all Amasty extensions compatible with each other?

        Yes, our extensions are fully compatible with each other and don't cause any conflicts while using them together on one Magento instance. However, if any specific integration between the modules is required, please contact us with the details of the ...
      • Is your extension compatible with my third-party module/theme?

        Amasty started testing extensions with Hyvä theme. The list of extensions with implemented compatibility can be found in this article: What Amasty extensions have Hyva compatibility and how to install Hyva packages? We don't test our extensions with ...